FW: [Kuka-LWR] RSI - README & INSTALL files

In a discussion on the LWR mailing list, an issue related to the fosi.h file using Xenomai came up, see the messages below. Does anyone have an idea what might be going wrong?

Wilm

From: Juan Pablo Zometa [mailto:jpmzometa [..] ...]
Sent: Tuesday, March 02, 2010 7:05 PM
To: Wilm Decré
Cc: Kuka-LWR [..] ...
Subject: Re: [Kuka-LWR] RSI - README & INSTALL files

Hi Wilm.

I installed eigen ($ rosmake eigen), and still could not compile the kdl-1.0 package. The error was in the kdl Makefile, I changed the line:
EIGEN2_INCLUDE_DIR=`rospack find eigen`/build/eigen2/
to this (removed a '2')
EIGEN2_INCLUDE_DIR=`rospack find eigen`/build/eigen/

Then the kdl-1.0 installation went ok, but a few steps later I got yet another error!
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191: error: 'rtos_sem_wait' declared as an 'inline' variable
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191: error: 'rt_sem_t' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191: error: 'm' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:192: error: expected ',' or ';' before '{' token
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197: error: 'rtos_sem_trywait' declared as an 'inline' variable
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197: error: 'rt_sem_t' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197: error: 'm' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:198: error: expected ',' or ';' before '{' token
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203: error: 'rtos_sem_value' declared as an 'inline' variable
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203: error: 'rt_sem_t' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203: error: 'm' was not declared in this scope
/export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:204: error: expected ',' or ';' before '{' token
In file included from /usr/include/boost/detail/sp_typeinfo.hpp:57,
from /usr/include/boost/smart_ptr/detail/sp_counted_base_gcc_x86.hpp:27,
from /usr/include/boost/smart_ptr/detail/sp_counted_base.hpp:36,
from /usr/include/boost/smart_ptr/detail/shared_count.hpp:29,
from /usr/include/boost/smart_ptr/shared_ptr.hpp:32,
from /usr/include/boost/shared_ptr.hpp:17,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/ActionInterface.hpp:42,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/CommandInterface.hpp:41,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/DataSourceBase.hpp:48,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/DataSource.hpp:47,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/Attribute.hpp:42,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/AttributeRepository.hpp:44,
from /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/TaskContext.hpp:42,
from /export/home/localadm/ros/pkgs/Kuka_RSI/src/RSIInterface.hpp:25,
from /export/home/localadm/ros/pkgs/Kuka_RSI/src/RSIInterface.cpp:33:
/usr/include/c++/4.4/typeinfo:36: error: expected '}' before end of line
/usr/include/c++/4.4/typeinfo:36: error: expected declaration before end of line
make[3]: *** [CMakeFiles/RSIInterface.dir/src/RSIInterface.o] Fehler 1

I previously had problems with the fosi.h for xenomai while installing it using cmake (even posted it in the forum). I tried to back trace this error but did not find any probable fix. Any ideas?

Thanks for your help.
2010/3/2 Wilm Decré <Wilm [dot] Decre [..] ...<mailto:Wilm [dot] Decre [..] ...>>
Hello Juan Pablo,

Can you try the following:

1. Remove the libreadline5-dev rosdep dependency in the ocl manifest.xml file (we are not sure yet why there is a warning because of this)

2. Also build kdl-1.0 (like ocl and rtt as a package from our server). Although the RSI component does not depend on kdl directly, ocl does depend on kdl, so we will need it too... sorry for the confusion.

3. Install eigen (a linear algebra library that kdl uses). You can find this as a ROS package in the ROS geometry stack.

Wilm

From: Juan Pablo Zometa [mailto:jpmzometa [..] ...<mailto:jpmzometa [..] ...>]
Sent: Tuesday, March 02, 2010 2:24 PM
To: Wilm Decré
Cc: Kuka-LWR [..] ...<mailto:Kuka-LWR [..] ...>

Subject: Re: [Kuka-LWR] RSI - README & INSTALL files

Hi Wilm.

I got 1 warning and 1 error:
The warning:
[ rosmake ] Checking rosdeps compliance for packages Kuka_RSI. This may take a few seconds.
Failed to find rosdep libreadline5-dev for package Kuka_RSI
WARNING: Rosdeps [u'libreadline5-dev'] could not be resolved

however, the libreadline5-dev _is_ installed in my system (ubuntu-9.10), a $ sudo apt-get install libreadline5-dev returns "libreadline5-dev is already the latest version".

The error:
The installer keeps asking me for a KDL installation. I modified the makefiles and manifest.xml to try to avoid this error commented out the lines containing KDL and BFL. That did not work, though. One of many messages I get:
ros/pkgs/orocos-pkgs/kdl/kdl-1.0/kdl-svn/src/jntarray.hpp:72: error: 'Eigen' has not been declared

My orocos_target is Xenomai, so I also changed that.

It also noticed that the ENABLE_CORBA flag was set. I just installed Omnicorb4 to avoid the installer to fail. I guess I just have to also install the KDL and BFL.

So, some questions arise from this:
is Omnicorb necessary?
Why ROS did not find the libreadline-5-dev? what are the implications of this warning?
Why include the KRL and the BFL in the compilation process when they are not necessary?

Thanks a lot,

JPZ

2010/3/2 Wilm Decré <Wilm [dot] Decre [..] ...<mailto:Wilm [dot] Decre [..] ...>>
Juan Pablo,

For the RTT and OCL dependencies, I think it is best to also get the Orocos packages we created for them. (I will add this to the readme file, since this is indeed not clear...)

You can find these at:
http://svn.mech.kuleuven.be/repos/orocos/orocos-apps/public_release/oroc...

The RSI component does not depend on kdl and bfl; only rtt and ocl are required.

Wilm

From: Juan Pablo Zometa [mailto:jpmzometa [..] ...<mailto:jpmzometa [..] ...>]
Sent: Tuesday, March 02, 2010 11:48 AM
To: Wilm Decré
Cc: kuka-lwr [..] ...<mailto:kuka-lwr [..] ...>
Subject: Re: [Kuka-LWR] RSI - README & INSTALL files

Hi Wilm.
Thanks for the README file, things are a little bit clearer now. However the INSTALL process is still misterious for me. What I've done so far:

mv the Kuka_RSI directory to ~/ros/pkgs
tried
$ rosmake lwr
but did not find the package "lwr".
tried
$ rosmake Kuka_RSI
and did not find my rtt and ocl installation. They were installed using cmake. I tried to cheat and simply created all the dependencies using:
$ roscreate-pkg rtt-1.10
and so on for ocl-1.10, kdl-1.0 bfl-0.7. Again issued a
$ rosmake Kuka_RSI
it started compiled but finally I got this message:

[ rosmake ] Output from build of package Kuka_RSI written to:
[ rosmake ] /export/home/localadm/.ros/rosmake/rosmake_output-20100302-112540/Kuka_RSI/build_output.log
[rosmake-1] <<< Kuka_RSI <<< [FAIL] [ 0.43 seconds ]
[ rosmake ] Halting due to failure in package Kuka_RSI.
[ rosmake ] Waiting for other threads to complete.
[rosmake-3] <<< roslib <<< [PASS] [ 0.83 seconds ]
[ rosmake ] Summary output to directory
[ rosmake ] /export/home/localadm/.ros/rosmake/rosmake_output-20100302-112540

looking at the build_output.log file,

cd build && make -j4 && make install
make[1]: Betrete Verzeichnis '/export/home/localadm/ros/pkgs/Kuka_RSI/build'
make[1]: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
make[1]: Verlasse Verzeichnis '/export/home/localadm/ros/pkgs/Kuka_RSI/build'
make: *** [installed] Fehler 2

my system is in german (sorry for that), but it just means there were no targets given and that it could not find a >make< file.

This procedure is obviously wrong, but I did not find another way to compile.

Regards,

2010/3/1 Wilm Decré <Wilm [dot] Decre [..] ...<mailto:Wilm [dot] Decre [..] ...>>
Dear Juan Pablo,

From: kuka-lwr-bounces [..] ...<mailto:kuka-lwr-bounces [..] ...> [mailto:kuka-lwr-bounces [..] ...<mailto:kuka-lwr-bounces [..] ...>] On Behalf Of Juan Pablo Zometa
Sent: Saturday, February 27, 2010 12:35 PM
To: kuka-lwr [..] ...<mailto:kuka-lwr [..] ...>
Subject: [Kuka-LWR] RSI - README & INSTALL files

Hi.

I tried to compile the RSI Component using the ROS build system without success. It would be nice to have the typical README and INSTALL files included in the directory tree. I am already willing to test a few things with the LWR, so I'll be glad to have a guide on how to install and use the RSI component and the examples as soon as you can.

I have just uploaded a readme.txt file that gives a brief overview of the different directories and files of the software.

Installing the software -should- be

- adding the path to your ROS structure
- execute rosmake lwr

If you can send us the build output you get (with all information you think is relevant), we can have a look at what might be going wrong.

Wilm

Thanks for your great work.

_______________________________________________
Kuka-LWR mailing list
Kuka-LWR [..] ...<mailto:Kuka-LWR [..] ...>
http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr

_______________________________________________
Kuka-LWR mailing list
Kuka-LWR [..] ...<mailto:Kuka-LWR [..] ...>
http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr

_______________________________________________
Kuka-LWR mailing list
Kuka-LWR [..] ...<mailto:Kuka-LWR [..] ...>
http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr

Makefile pkg-rtt xenomai

Hello Ruben.

Attached the modified Makefile I used to compile against Xenomai target.

PS: I added the extra .txt extension, otherwise I get an attachment error.

Makefile pkg-rtt xenomai

Hello Ruben.

Attached the modified Makefile I used to compile against Xenomai target.

PS: I added the extra .txt extension, otherwise I get an attachment error.

Ruben Smits's picture

Makefile pkg-rtt xenomai

On Thu, Mar 11, 2010 at 11:15 AM, jpmzometa [..] ...
<jpmzometa [..] ...> wrote:
> Hello Ruben.
>
> Attached the modified Makefile I used to compile against Xenomai target.

The Makefile looks fine. I checked the rtt-1.10 branch if it contains
the fix for the bug you reported previously, so it should work. Is the
error you get now exactly the same as you previously had?

Ruben

> PS: I added the extra .txt extension, otherwise I get an attachment error.
>
>

Makefile pkg-rtt xenomai

Oh, I forgot to point that out, sorry. It is _not_ the same error.
Additional info: I compiled without problems using the Makefile for gnulinux
target.

2010/3/11 Ruben Smits <ruben [dot] smits [..] ...>

> On Thu, Mar 11, 2010 at 11:15 AM, jpmzometa [..] ...
> <jpmzometa [..] ...> wrote:
> > Hello Ruben.
> >
> > Attached the modified Makefile I used to compile against Xenomai target.
>
> The Makefile looks fine. I checked the rtt-1.10 branch if it contains
> the fix for the bug you reported previously, so it should work. Is the
> error you get now exactly the same as you previously had?
>
> Ruben
>
>
> > PS: I added the extra .txt extension, otherwise I get an attachment
> error.
> >
> >
>

Ruben Smits's picture

FW: [Kuka-LWR] RSI - README & INSTALL files

You can check Xenomai related installation instructions at:
http://www.orocos.org/stable/documentation/rtt/v1.10.x/doc-xml/orocos-in...

Ruben

On Mon, Mar 8, 2010 at 4:01 PM, Wilm Decré <Wilm [dot] Decre [..] ...> wrote:
> In a discussion on the LWR mailing list, an issue related to the fosi.h file
> using Xenomai came up, see the messages below. Does anyone have an idea what
> might be going wrong?
>
>
>
> Wilm
>
>
>
> From: Juan Pablo Zometa [mailto:jpmzometa [..] ...]
> Sent: Tuesday, March 02, 2010 7:05 PM
> To: Wilm Decré
> Cc: Kuka-LWR [..] ...
> Subject: Re: [Kuka-LWR] RSI - README & INSTALL files
>
>
>
> Hi Wilm.
>
> I installed eigen ($ rosmake eigen), and still could not compile the kdl-1.0
> package. The error was in the kdl Makefile, I changed the line:
> EIGEN2_INCLUDE_DIR=`rospack find eigen`/build/eigen2/
> to this (removed a '2')
> EIGEN2_INCLUDE_DIR=`rospack find eigen`/build/eigen/
>
> Then the kdl-1.0 installation went ok, but a few steps later I got yet
> another error!
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191:
> error: ‘rtos_sem_wait’ declared as an ‘inline’ variable
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191:
> error: ‘rt_sem_t’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:191:
> error: ‘m’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:192:
> error: expected ‘,’ or ‘;’ before ‘{’ token
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197:
> error: ‘rtos_sem_trywait’ declared as an ‘inline’ variable
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197:
> error: ‘rt_sem_t’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:197:
> error: ‘m’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:198:
> error: expected ‘,’ or ‘;’ before ‘{’ token
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203:
> error: ‘rtos_sem_value’ declared as an ‘inline’ variable
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203:
> error: ‘rt_sem_t’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:203:
> error: ‘m’ was not declared in this scope
>
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/os/xenomai/fosi.h:204:
> error: expected ‘,’ or ‘;’ before ‘{’ token
>   In file included from /usr/include/boost/detail/sp_typeinfo.hpp:57,
>                    from
> /usr/include/boost/smart_ptr/detail/sp_counted_base_gcc_x86.hpp:27,
>                    from
> /usr/include/boost/smart_ptr/detail/sp_counted_base.hpp:36,
>                    from
> /usr/include/boost/smart_ptr/detail/shared_count.hpp:29,
>                    from /usr/include/boost/smart_ptr/shared_ptr.hpp:32,
>                    from /usr/include/boost/shared_ptr.hpp:17,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/ActionInterface.hpp:42,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/CommandInterface.hpp:41,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/DataSourceBase.hpp:48,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/DataSource.hpp:47,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/Attribute.hpp:42,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/AttributeRepository.hpp:44,
>                    from
> /export/home/localadm/ros/pkgs/orocos-pkgs/rtt/rtt-1.10/rtt/include/rtt/TaskContext.hpp:42,
>                    from
> /export/home/localadm/ros/pkgs/Kuka_RSI/src/RSIInterface.hpp:25,
>                    from
> /export/home/localadm/ros/pkgs/Kuka_RSI/src/RSIInterface.cpp:33:
>   /usr/include/c++/4.4/typeinfo:36: error: expected ‘}’ before end of line
>   /usr/include/c++/4.4/typeinfo:36: error: expected declaration before end
> of line
>   make[3]: *** [CMakeFiles/RSIInterface.dir/src/RSIInterface.o] Fehler 1
>
> I previously had problems with the fosi.h for xenomai while installing it
> using cmake (even posted it in the forum). I tried to back trace this error
> but did not find any probable fix. Any ideas?
>
> Thanks for your help.
>
> 2010/3/2 Wilm Decré <Wilm [dot] Decre [..] ...>
>
> Hello Juan Pablo,
>
>
>
> Can you try the following:
>
>
>
> 1.       Remove the libreadline5-dev rosdep dependency in the ocl
> manifest.xml file (we are not sure yet why there is a warning because of
> this)
>
> 2.       Also build kdl-1.0 (like ocl and rtt as a package from our server).
> Although the RSI component does not depend on kdl directly, ocl does depend
> on kdl, so we will need it too… sorry for the confusion.
>
> 3.       Install eigen (a linear algebra library that kdl uses). You can
> find this as a ROS package in the ROS geometry stack.
>
>
>
> Wilm
>
>
>
> From: Juan Pablo Zometa [mailto:jpmzometa [..] ...]
> Sent: Tuesday, March 02, 2010 2:24 PM
> To: Wilm Decré
> Cc: Kuka-LWR [..] ...
>
> Subject: Re: [Kuka-LWR] RSI - README & INSTALL files
>
>
>
> Hi Wilm.
>
> I got 1 warning and 1 error:
> The warning:
> [ rosmake ] Checking rosdeps compliance for packages Kuka_RSI.  This may
> take a few seconds.
> Failed to find rosdep libreadline5-dev for package Kuka_RSI
> WARNING: Rosdeps [u'libreadline5-dev'] could not be resolved
>
> however, the libreadline5-dev _is_ installed in my system (ubuntu-9.10), a $
> sudo apt-get install libreadline5-dev returns "libreadline5-dev is already
> the latest version".
>
> The error:
> The installer keeps asking me for a KDL installation. I modified the
> makefiles and manifest.xml to try to avoid this error commented out the
> lines containing KDL and BFL. That did not work, though. One of many
> messages I get:
> ros/pkgs/orocos-pkgs/kdl/kdl-1.0/kdl-svn/src/jntarray.hpp:72: error: ‘Eigen’
> has not been declared
>
> My orocos_target is Xenomai, so I also changed that.
>
> It also noticed that the ENABLE_CORBA flag was set. I just installed
> Omnicorb4 to avoid the installer to fail. I guess I just have to also
> install the KDL and BFL.
>
> So, some questions arise from this:
> is Omnicorb necessary?
> Why ROS did not find the libreadline-5-dev? what are the implications of
> this warning?
> Why include the KRL and the BFL in the compilation process when they are not
> necessary?
>
> Thanks a lot,
>
> JPZ
>
>
> 2010/3/2 Wilm Decré <Wilm [dot] Decre [..] ...>
>
> Juan Pablo,
>
>
>
> For the RTT and OCL dependencies, I think it is best to also get the Orocos
> packages we created for them. (I will add this to the readme file, since
> this is indeed not clear…)
>
>
>
> You can find these at:
>
> http://svn.mech.kuleuven.be/repos/orocos/orocos-apps/public_release/oroc...
>
>
>
> The RSI component does not depend on kdl and bfl; only rtt and ocl are
> required.
>
>
>
> Wilm
>
>
>
>
>
> From: Juan Pablo Zometa [mailto:jpmzometa [..] ...]
>
> Sent: Tuesday, March 02, 2010 11:48 AM
> To: Wilm Decré
>
> Cc: kuka-lwr [..] ...
> Subject: Re: [Kuka-LWR] RSI - README & INSTALL files
>
>
>
> Hi Wilm.
> Thanks for the README file, things are a little bit clearer now. However the
> INSTALL process is still misterious for me.  What I've done so far:
>
> mv the Kuka_RSI directory to ~/ros/pkgs
> tried
> $ rosmake lwr
> but did not find the package "lwr".
> tried
> $ rosmake Kuka_RSI
> and did not find my rtt and ocl installation. They were installed using
> cmake. I tried to cheat and simply created all the dependencies using:
> $ roscreate-pkg rtt-1.10
> and so on for ocl-1.10, kdl-1.0  bfl-0.7.  Again issued a
> $ rosmake Kuka_RSI
> it started compiled but finally I got this message:
>
> [ rosmake ] Output from build of package Kuka_RSI written to:
> [ rosmake ]
> /export/home/localadm/.ros/rosmake/rosmake_output-20100302-112540/Kuka_RSI/build_output.log
> [rosmake-1] <<< Kuka_RSI <<< [FAIL] [ 0.43 seconds ]
> [ rosmake ] Halting due to failure in package Kuka_RSI.
> [ rosmake ] Waiting for other threads to complete.
> [rosmake-3] <<< roslib <<< [PASS] [ 0.83 seconds ]
> [ rosmake ] Summary output to directory
> [ rosmake ]
> /export/home/localadm/.ros/rosmake/rosmake_output-20100302-112540
>
> looking at the build_output.log file,
>
> cd build && make -j4 && make install
> make[1]: Betrete Verzeichnis '/export/home/localadm/ros/pkgs/Kuka_RSI/build'
> make[1]: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.
> Schluss.
> make[1]: Verlasse Verzeichnis
> '/export/home/localadm/ros/pkgs/Kuka_RSI/build'
> make: *** [installed] Fehler 2
>
> my system is in german (sorry for that), but it just means there were no
> targets given and that it could not find a >make< file.
>
> This procedure is obviously wrong, but I did not find another way to
> compile.
>
> Regards,
>
>
>
> 2010/3/1 Wilm Decré <Wilm [dot] Decre [..] ...>
>
> Dear Juan Pablo,
>
>
>
> From: kuka-lwr-bounces [..] ...
> [mailto:kuka-lwr-bounces [..] ...] On Behalf Of Juan Pablo
> Zometa
> Sent: Saturday, February 27, 2010 12:35 PM
> To: kuka-lwr [..] ...
> Subject: [Kuka-LWR] RSI - README & INSTALL files
>
>
>
> Hi.
>
> I tried to compile the RSI Component using the ROS build system without
> success. It would be nice to have the typical README and INSTALL files
> included in the directory tree. I am already willing to test a few things
> with the LWR, so I'll be glad to have a guide on how to install and use the
> RSI component and the examples as soon as you can.
>
>
>
> I have just uploaded a readme.txt file that gives a brief overview of the
> different directories and files of the software.
>
>
>
> Installing the software -should- be
>
>
>
> - adding the path to your ROS structure
>
> - execute rosmake lwr
>
>
>
> If you can send us the build output you get (with all information you think
> is relevant), we can have a look at what might be going wrong.
>
>
>
> Wilm
>
> Thanks for your great work.
>
>
>
> _______________________________________________
> Kuka-LWR mailing list
> Kuka-LWR [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr
>
>
>
>
>
> _______________________________________________
> Kuka-LWR mailing list
> Kuka-LWR [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr
>
>
>
> _______________________________________________
> Kuka-LWR mailing list
> Kuka-LWR [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/kuka-lwr
>
>

Hi Ruben.I have previously

Hi Ruben.

I have previously installed the RTT in my computer using cmake. Now the problem is that it does not compile when I try to build (on the same computer, with the same software configuration) the RTT using the Orocos' ROS packages.

Previously I did _not_ use the SVN version of RTT (the ROS package, as you might know, downloads the latest RTT SVN version), which indeed had a problem with the fosi.h for xenomai. Peter sent me a modified fosi.h against which I could succesfully compile using cmake. This new fosi.h should already be in the SVN, though.

Could it be that my existing/previous RTT installation is conflicting with the newer compilation process? could it also be related to the SVN version? Lately, I have not tried to compile in the hope I would get a probable solution. I might just run some compilation test and let you know the results.

Regards,

Hi Ruben.I have previously

Hi Ruben.

I have previously installed the RTT in my computer using cmake. Now the problem is that it does not compile when I try to build (on the same computer, with the same software configuration) the RTT using the Orocos' ROS packages.

Previously I did _not_ use the SVN version of RTT (the ROS package, as you might know, downloads the latest RTT SVN version), which indeed had a problem with the fosi.h for xenomai. Peter sent me a modified fosi.h against which I could succesfully compile using cmake. This new fosi.h should already be in the SVN, though.

Could it be that my existing/previous RTT installation is conflicting with the newer compilation process? could it also be related to the SVN version? Lately, I have not tried to compile in the hope I would get a probable solution. I might just run some compilation test and let you know the results.

Regards,

Ruben Smits's picture

Hi Ruben.I have previously

On Wed, Mar 10, 2010 at 11:53 AM, jpmzometa [..] ...
<jpmzometa [..] ...> wrote:
> Hi Ruben.
>
> I have previously installed the RTT in my computer using cmake. Now the problem is that it does not compile when I try to build (on the same computer, with the same software configuration) the RTT using the Orocos' ROS packages.

The ROS packages do not support builds for xenomai yet, but it should
be fairly easy to fix the Makefile yourself.

> Previously I did _not_ use the SVN version of RTT (the ROS package, as you might know, downloads the latest RTT SVN version), which indeed had a problem with the fosi.h for xenomai. Peter sent me a modified fosi.h against which I could succesfully compile using cmake. This new fosi.h should already be in the SVN, though.

I don't know exactly if the fosi.h of the rtt-1.10 branch is updated
to include the fix.

> Could it be that my existing/previous RTT installation is conflicting with the newer compilation process? could it also be related to the SVN version? Lately, I have not tried to compile in the hope I would get a probable solution. I might just run some compilation test and let you know the results.

The new compilation should be unaware of your already existing RTT installation.

Did you modify the Makefile of the ROS package for the Xenomai target?
If so, could you show me your changes, maybe something obvious is
still wrong.

Ruben

> Regards,
> --
> Orocos-Users mailing list
> Orocos-Users [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/orocos-users
>