Fwd: [Bug 291257] [Widgets] Buttons functionality problem with GTK+ 2.18


For those of you using eclipse and a newer distribution of Linux then
it might be worthwhile to download the "Integration" build. I have not
tested it yet.



---------- Forwarded message ----------
From: <bugzilla-daemon [..] ...>
Date: Wed, Nov 25, 2009 at 1:06 PM
Subject: [Bug 291257] [Widgets] Buttons functionality problem with GTK+ 2.18
To: hugo [dot] a [dot] garcia [..] ...

Product/Component: Platform / SWT

--- Comment #46 from Phillip Beauvoir <p [dot] beauvoir [..] ...>
2009-11-25 12:58:24 EST ---
(In reply to comment #45)
> As Remy noted, we've backported the fixes we've put in to 3.6 for 2.18 issues
> into the 3.5.x maintenance stream. The best thing to do is to try out your app
> using a recent 3.5.x build (either last week's or today's) and let us know if
> you are still having problems.

Thanks Bogdan and Remy for that information (I tried to find out if it had been
backported before I posted on here but couldn't find anything.) Anyway, I tried
it with the Eclipse build SDK-M20091118-0800 and it fixed the button problem,
so I shall rebuild our RCP apps against that. Great stuff, thanks!

BTW - I did notice in Eclipse's Update Manager window on Ubuntu that the
Tree-table was not displaying properly. Is this related to this bug?

Configure bugmail: https://bugs.eclipse.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.