orocreate-pkg: compile

2011/4/8 eberlid [..] ... <eberlid [..] ...>

> typegen is located at
> &#10;&gt;&#10;&gt; /home/eberlid/orocos_toolchain_ros/orogen/build/orocos-toolchain-orogen/bin/typegen&#10;&gt;
>
> and the content of the path variable is
> &#10;&gt;&#10;&gt; /opt/ros/cturtle/ros/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games&#10;&gt;
>
> so it isn't listed in the PATH. I listed it in the .bashrc and tried again.
> Now the error is
>
> &#10;&gt; Building component HelloWorld in library HelloWorld-gnulinux&#10;&gt; Generating typekit for HelloWorld...&#10;&gt; CMake Error at&#10;&gt; /home/eberlid/orocos_toolchain_ros/rtt/install/lib/cmake/orocos-rtt/UseOROCOS-RTT.cmake:253&#10;&gt; (add_subdirectory):&#10;&gt;  add_subdirectory given source &quot;typekit&quot; which is not an existing&#10;&gt; directory.&#10;&gt; Call Stack (most recent call first):&#10;&gt;  CMakeLists.txt:55 (orocos_typegen_headers)&#10;&gt;&#10;&gt;&#10;&gt; -- Configuring incomplete, errors occurred!&#10;&gt; make: *** [all] Error 1&#10;&gt;
>
> can you help me with this error?
>

If you're not interested in building typekits, open the CMakeLists.txt and
disable the line that says "orocos_typegen_headers()"
The orocos macro's used to enabled this by default. By default it is
disabled however as of version 2.3.

Regards,

Steven

> Thanks!
> dani
> --
> Orocos-Users mailing list
> Orocos-Users [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/orocos-users
>

Re: orocreate-pkg: compile

Steven Bellens wrote:

If you're not interested in building typekits, open the CMakeLists.txt and disable the line that says "orocos_typegen_headers()" The orocos macro's used to enabled this by default. By default it is disabled however as of version 2.3.

Regards,

Steven

It works!

Thanks alot Dani