Resource not found [rtt_ros_integration_std_msgs]

Hi All, I'm trying to build the ndi_hardware package in my ROS & OROCOS installation, with ROS fuerte, installed as seen here.

when I check with rosdep for the dependencies, I get the following two problems

ERROR[ndi_polaris_orocos_example]: resource not found [rtt_1.10]
ERROR[ndi_polaris_orocos_tf]: resource not found [rtt_ros_integration_std_msgs]
that are related to the orocos installation.

For the rtt_ros_integration_std_msgs, I do not have this package and it is no longer present in the rtt_ros_integration and I do not know where to find it. I tried to comment it out in the manifest.xml file, and now during rosmake I got a problem of rtt_ros_integration not present

Error: package/stack ndi_polaris_orocos_tf depends on non-existent package rtt_ros_integration

which it was installed and compiled during the installation process and I can go in that folder using roscd. But I think it is the good solution to remove the dependency on rtt_ros_integration_std_msgs.

For the rtt_1.10 I edited the manifest file of the ndi_polaris_example removing the _1.10 in rtt and ocl but I get the following errors:

In file included from /home/user/ros_workspace/orocos/orocos_toolchain/log4cpp/../install/include/rtt/RTT.hpp:38:0,
                   from /home/user/ros_workspace/orocos/ndi_hardware/ndi_polaris_orocos_example/src/PoseMeasurementSystem.hpp:23,
                   from /home/user/ros_workspace/orocos/ndi_hardware/ndi_polaris_orocos_example/src/PoseMeasurementSystem.cpp:20:
  /home/user/ros_workspace/orocos/orocos_toolchain/log4cpp/../install/include/rtt/rtt-config.h:12:2: error: #error "You _must_ define OROCOS_TARGET to an installed target (for example: -DOROCOS_TARGET=gnulinux )"
  In file included from /home/user/ros_workspace/orocos/orocos_toolchain/log4cpp/../install/include/rtt/rtt-config.h:15:0,
                   from /home/user/ros_workspace/orocos/orocos_toolchain/log4cpp/../install/include/rtt/RTT.hpp:38,
                   from /home/user/ros_workspace/orocos/ndi_hardware/ndi_polaris_orocos_example/src/PoseMeasurementSystem.hpp:23,
                   from /home/user/ros_workspace/orocos/ndi_hardware/ndi_polaris_orocos_example/src/PoseMeasurementSystem.cpp:20:
  /home/user/ros_workspace/orocos/orocos_toolchain/log4cpp/../install/include/rtt/os/targets/rtt-target.h:13:30: fatal error: OROCOS_TARGET-config.h: No such file or directory
  compilation terminated.
  make[3]: *** [CMakeFiles/ndi_polaris_orocos_example.dir/src/PoseMeasurementSystem.o] Error 1
even if I have the OROCOS_TARGET environment variable set

Do anybody has an idea about that problems?

Thank you for your help,



frodo's picture

Resource not found

I was trying to compile some days ago the same package and also found the problem of the OROCOS_TARGET definition. It was solved adding the following line to the CMakeLists.txt


Also my manifest.xml file doesn't have the '_1.10', but I am working with the package called: ndi_polaris_orocos_20_example