RTNet, SOEM: getting socket index failed

I have now enabled RTNet. I have the exact same error as in this topic: <http://www.orocos.org/forum/orocos/orocos-users/soem-and-rtnet> which is: > sudo bin/slaveinfo rteth0 > SOEM (Simple Open EtherCAT Master) > Slaveinfo > Starting slaveinfo > getting socket index failed:-1, Operation not permitted

This comes from the soem_core/build/soem_core/src/nicdrv.c file, at about line 230.

Ruben said this was fixed, but I am pretty sure I have the latest version of SOEM. Plus, I have evidence that my RTNet configuration should be fine. When I run an example from RTNet (namely, the raw-ethernet executable in /RTNet-install-path/examples/xenomai/posix), which does _exactly_ the same thing as slaveinfo (line 78 of raw-ethernet.c), there is no socket index fail.

Any idea how to fix it?


RTNet, SOEM: getting socket

It seems like when compiling Soem_core does not use the posix skin.

I noticed a line in the CMakeLists file in soem_core where it requires a "ENABLE_RTNET" variable which is set to false in build/CMakeCache...

This is the only difference with the ethercat executable I mentioned in my previous message. (according to ldd it uses the skin posix).