SIGSEGV with the TaskBrowser under xenomai

The TaskBrowser raises a SIGSEGV. We can produce the problem by starting the deployer-xenomai. The stack is :

#0  0xb780ac60 in xeno_sigwinch_handler () from /usr/lib/libxenomai.so.0
#1  0xb780ad66 in ?? () from /usr/lib/libxenomai.so.0
#2  0x0000001c in ?? ()
#3  0x00000000 in ?? ()

If we disable the readline library by setting NO_GPL at ON, the problem disappears. The problem seems to be related to problem with ncurses and readline. A quick google search links to a message from Peter at: //www [dot] mail-archive [dot] com/xenomai-help [..] .../msg10352.html">http://www [dot] mail-archive [dot] com/xenomai-help [..] .../msg10352.html

As suggested, I tried to add xeno_sigwinch_handler in the TaskBrowser code, but I did not manage to link...

Nicolas

SIGSEGV with the TaskBrowser under xenomai

The TaskBrowser raises a SIGSEGV.
We can produce the problem by starting the deployer-xenomai.
The stack is :

#0  0xb780ac60 in xeno_sigwinch_handler () from /usr/lib/libxenomai.so.0
#1  0xb780ad66 in ?? () from /usr/lib/libxenomai.so.0
#2  0x0000001c in ?? ()
#3  0x00000000 in ?? ()


If we disable the readline library by setting NO_GPL at ON, the problem disappears.
The problem seems to be related to problem with ncurses and readline.
A quick google search links to a message from Peter at:
[http://www [dot] mail-archive [dot] com/xenomai-help [..] .../msg10352.html]

As suggested, I tried to add xeno_sigwinch_handler in the TaskBrowser code, but I did not manage to link...

Nicolas
<!--break-->