newly created wiki page does not get correct automatic url alias and therefore also not the left wiki navigation column

Hi all,

When creating a new wiki page, the url path seems to be automatically set to main-page instead of to wiki.
As a result, the left wiki navigation column is not shown.
You can (temporarily?) bypass this by going to your wiki page, edit, and uncheck "Generate automatic URL alias" and then change the main-page by wiki in the custom alias entry field.

Tinne

newly created wiki page does not get correct automatic url alias

Hi Tinne,

On Mon, Jan 23, 2012 at 9:56 AM, Tinne De Laet <
Tinne [dot] DeLaet [..] ...> wrote:

> Hi all,
>
> When creating a new wiki page, the url path seems to be automatically set
> to main-page instead of to wiki.
> As a result, the left wiki navigation column is not shown.
> You can (temporarily?) bypass this by going to your wiki page, edit, and
> uncheck "Generate automatic URL alias" and then change the main-page by
> wiki in the custom alias entry field.
>

Yes, this bypass is 'legal'. I'll look into it why the automatic alias is
wrong...and keep you posted.

Peter

newly created wiki page does not get correct automatic url alias

On Tue, Jan 24, 2012 at 11:22 AM, Ruben Smits <ruben [..] ...>wrote:

>
>
> On Tue, Jan 24, 2012 at 9:47 AM, Tinne De Laet <
> tinne [dot] delaet [..] ...> wrote:
>
>> On Monday 23 January 2012 15:04:33 Peter Soetens wrote:
>> > Hi Tinne,
>> >
>> > I have tested and fixed the wiki url generation. Can you verify that it
>> > works now ? There's also a sandbox area where you can play with creating
>> > wiki pages.
>>
>> Works like a charm now ;)
>>
>>
> I do not agree ;), most links on http://www.orocos.org/toolchain are
> broken ATM
>

Hmm... I was wondering. We're having a mix between wiki/orocos/<topic> and
wiki/<topic>

I believe the latter version was the correct one, so I'll update the
aliasing scheme to drop the 'orocos' part.

Note that this might then break some recent links in itasc (if you
hard-linked to it by URL ).

Peter

>
>
>> Thanks,
>>
>> Tinne
>>
>
> Ruben
>
>
>> --
>> Orocos-Dev mailing list
>> Orocos-Dev [..] ...
>> http://lists.mech.kuleuven.be/mailman/listinfo/orocos-dev
>>
>
>
>
> --
> Ruben Smits, Phd
> Chief Technology Officer
> Intermodalics BVBA
> +32479511786
> www.intermodalics.eu
>
>

newly created wiki page does not get correct automatic url alias

On 01/24/2012 11:41 AM, Peter Soetens wrote:
> On Tue, Jan 24, 2012 at 11:22 AM, Ruben Smits <ruben [..] ... <mailto:ruben [..] ...>> wrote:
>
>
>
> On Tue, Jan 24, 2012 at 9:47 AM, Tinne De Laet <tinne [dot] delaet [..] ... <mailto:tinne [dot] delaet [..] ...>> wrote:
>
> On Monday 23 January 2012 15:04:33 Peter Soetens wrote:
> > Hi Tinne,
> >
> > I have tested and fixed the wiki url generation. Can you verify that it
> > works now ? There's also a sandbox area where you can play with creating
> > wiki pages.
>
> Works like a charm now ;)
>
>
> I do not agree ;), most links on http://www.orocos.org/toolchain are broken ATM
>
>
> Hmm... I was wondering. We're having a mix between wiki/orocos/<topic> and wiki/<topic>
>
> I believe the latter version was the correct one, so I'll update the aliasing scheme to drop the 'orocos' part.
>
> Note that this might then break some recent links in itasc (if you hard-linked to it by URL ).
didn't encounter any problems there
>
> Peter
>
> Thanks,
>
> Tinne
>
>
> Ruben
>
> --
> Orocos-Dev mailing list
> Orocos-Dev [..] ... <mailto:Orocos-Dev [..] ...>
> http://lists.mech.kuleuven.be/mailman/listinfo/orocos-dev
>
>
>
>
> --
> Ruben Smits, Phd
> Chief Technology Officer
> Intermodalics BVBA
> +32479511786 <tel:%2B32479511786>
> www.intermodalics.eu <http://www.intermodalics.eu>
>
>

newly created wiki page does not get correct automatic url alias

Hi Tinne,

I have tested and fixed the wiki url generation. Can you verify that it
works now ? There's also a sandbox area where you can play with creating
wiki pages.

Peter

On Mon, Jan 23, 2012 at 2:38 PM, Peter Soetens <peter [..] ...>wrote:

> Hi Tinne,
>
> On Mon, Jan 23, 2012 at 9:56 AM, Tinne De Laet <
> Tinne [dot] DeLaet [..] ...> wrote:
>
>> Hi all,
>>
>> When creating a new wiki page, the url path seems to be automatically set
>> to main-page instead of to wiki.
>> As a result, the left wiki navigation column is not shown.
>> You can (temporarily?) bypass this by going to your wiki page, edit, and
>> uncheck "Generate automatic URL alias" and then change the main-page by
>> wiki in the custom alias entry field.
>>
>
> Yes, this bypass is 'legal'. I'll look into it why the automatic alias is
> wrong...and keep you posted.
>
> Peter
>
>

newly created wiki page does not get correct automatic url alias

On Monday 23 January 2012 15:04:33 Peter Soetens wrote:
> Hi Tinne,
>
> I have tested and fixed the wiki url generation. Can you verify that it
> works now ? There's also a sandbox area where you can play with creating
> wiki pages.

Works like a charm now ;)

Thanks,

Tinne

newly created wiki page does not get correct automatic url alias

On Tue, Jan 24, 2012 at 9:47 AM, Tinne De Laet <
tinne [dot] delaet [..] ...> wrote:

> On Monday 23 January 2012 15:04:33 Peter Soetens wrote:
> > Hi Tinne,
> >
> > I have tested and fixed the wiki url generation. Can you verify that it
> > works now ? There's also a sandbox area where you can play with creating
> > wiki pages.
>
> Works like a charm now ;)
>
>
I do not agree ;), most links on http://www.orocos.org/toolchain are broken
ATM

> Thanks,
>
> Tinne
>

Ruben

> --
> Orocos-Dev mailing list
> Orocos-Dev [..] ...
> http://lists.mech.kuleuven.be/mailman/listinfo/orocos-dev
>