Proposal to restructure orocos_toolchain_ros

I'd like to propose to restructure the orocos_toolchain_ros such that
new&existing users can more easily find their way. It's mainly about
renaming packages:

1. rtt_ros_integration -> rename to 'rtt_rosnode'
-> an import("rtt_rosnode") makes your process a ros node
2. rtt_ros_integration_xyz_msgs -> rename to 'rtt_xyz_msgs'
-> shorter notation, also makes it easier for users to update their
manifest file, just prefix with 'rtt_'
3. rtt_ros_param -> rename to 'rtt_rosparam'
-> consistent naming scheme, service is also named 'rosparam' and not
'ros_param'
4. rtt_ros_service -> ?
-> a bit confusing about what it does, I wonder if the code shouldn't
belong in rtt_rosnode instead, since it only provides the ros.topic()
operations, which make only sense when running in a rosnode... I would
also propose that this global 'ros' service is available from the
moment rtt_rosnode is imported. Today you need an extra
'require("ros")' in scripting and something similar in lua.

What do the current users/devs think ?

Peter