Quick start guide on Ubuntu 14.04

Hi folks,

The bootstrap script accessible from the Quick Start guide of the toolchain
is broken for Ubuntu 14.04.

I have first autoproj errors:

(...)
[all] gem,pip
autoproj: installing a proper Ruby environment (this can take a long time)
autoproj: installing autoproj and its dependencies (this can take a long
time)
installing/updating RubyGems dependencies: autobuild
installing/updating RubyGems dependencies: autoproj
operating system: ubuntu,debian - 14.04,14.04.1,lts,trusty,tahr

autodetected the shell to be bash, sourcing autoproj shell helpers
add "Autoproj.shell_helpers = false" in autoproj/init.rb to disable
checked out autoproj main configuration
bootstrap-2.6.sh: 1:
/home/lesire/work/mauve/orocos-toolchain/.gems/gems/autoproj-1.10.2/shell/autoproj_bash:
function: not found
bootstrap-2.6.sh: 2: local: not in a function

Then RTT build errors (due to RTT waiting for old Boost headers) :

In file included from
/home/lesire/work/mauve/orocos-toolchain/rtt/rtt/TaskContext.hpp:44:0,
from
/home/lesire/work/mauve/orocos-toolchain/rtt/rtt/ExecutionEngine.cpp:46:
/home/lesire/work/mauve/orocos-toolchain/rtt/rtt/Service.hpp:62:56: fatal
error: boost/smart_ptr/enable_shared_from_this2.hpp: No such file or
directory
#include <boost/smart_ptr/enable_shared_from_this2.hpp>
^
compilation terminated.

Is it completely broken or is there a working bootstrap somewhere?
In any case, the doc is not up to date...

Cheers,

Charles

Quick start guide on Ubuntu 14.04

> bootstrap-2.6.sh: 1:
> /home/lesire/work/mauve/orocos-toolchain/.gems/gems/autoproj-1.10.2/shell/autoproj_bash:
> function: not found
> bootstrap-2.6.sh: 2: local: not in a function
My guess is that bootstrap-2.6.sh uses "#! /bin/sh" which is now dash
on Debian (and probably ubuntu). dash does not know the "function ..."
syntax.

The issue is that the env.sh sources the shell helpers for the local
shell as specified by $SHELL (since we want the user to be able to
load it). If one then sources it from a different shell, boom ! I
guess that a good fix would be to make env.sh itself test for the
"local" shell type and load the right helper file.

Sylvain

Quick start guide on Ubuntu 14.04

2014-10-09 19:30 GMT+02:00 Sylvain Joyeux <sylvain [dot] joyeux [..] ...>:

> > bootstrap-2.6.sh: 1:
> >
> /home/lesire/work/mauve/orocos-toolchain/.gems/gems/autoproj-1.10.2/shell/autoproj_bash:
> > function: not found
> > bootstrap-2.6.sh: 2: local: not in a function
> My guess is that bootstrap-2.6.sh uses "#! /bin/sh" which is now dash
> on Debian (and probably ubuntu). dash does not know the "function ..."
> syntax.
>

you're right

>
> The issue is that the env.sh sources the shell helpers for the local
> shell as specified by $SHELL (since we want the user to be able to
> load it). If one then sources it from a different shell, boom ! I
> guess that a good fix would be to make env.sh itself test for the
> "local" shell type and load the right helper file.
>

and what? do you plan to make the change? soon?

>
> Sylvain
>