[rtt2] request the component to recover from an Exception state in CORBA

This is not covered by the CORBA IDL.

I propose to add a recoverException() call that calls recover.

Does that sound fine ?

[rtt2] request the component to recover from an Exception state

On Friday 06 August 2010 12:59:44 Sylvain Joyeux wrote:
> This is not covered by the CORBA IDL.
>
> I propose to add a recoverException() call that calls recover.
>
> Does that sound fine ?
>

Why the difference in naming C++ recover() <-> idl recoverException() ? Since
recover also recovers from the run-time error state, the suggested name is
misleading.

Peter

[rtt2] request the component to recover from an Exception state

On Friday 06 August 2010 16:31:52 Sylvain Joyeux wrote:
> On 08/06/2010 04:07 PM, Peter Soetens wrote:
> > On Friday 06 August 2010 12:59:44 Sylvain Joyeux wrote:
> >> This is not covered by the CORBA IDL.
> >>
> >> I propose to add a recoverException() call that calls recover.
> >>
> >> Does that sound fine ?
> >
> > Why the difference in naming C++ recover()<-> idl recoverException() ?
> > Since recover also recovers from the run-time error state, the suggested
> > name is misleading.
>
> There is a difference *because( recover() recovers from RUNTIME_ERROR
> and that is something recoverException should not do.
>
> Maybe reset_exception ? In the end, the method is not recovering from
> anything, it only acknowledges to the module that the exception has been
> noted and that the supervision layer decided to restart the component
> anyway.--

resetException() it is.

Peter

[rtt2] request the component to recover from an Exception state

On 08/06/2010 04:41 PM, Peter Soetens wrote:
> On Friday 06 August 2010 16:31:52 Sylvain Joyeux wrote:
>
>> On 08/06/2010 04:07 PM, Peter Soetens wrote:
>>
>>> On Friday 06 August 2010 12:59:44 Sylvain Joyeux wrote:
>>>
>>>> This is not covered by the CORBA IDL.
>>>>
>>>> I propose to add a recoverException() call that calls recover.
>>>>
>>>> Does that sound fine ?
>>>>
>>> Why the difference in naming C++ recover()<-> idl recoverException() ?
>>> Since recover also recovers from the run-time error state, the suggested
>>> name is misleading.
>>>
>> There is a difference *because( recover() recovers from RUNTIME_ERROR
>> and that is something recoverException should not do.
>>
>> Maybe reset_exception ? In the end, the method is not recovering from
>> anything, it only acknowledges to the module that the exception has been
>> noted and that the supervision layer decided to restart the component
>> anyway.--
>>
> resetException() it is.
>
Ah ... yes ... of course. My ruby is leaking to my C++ naming scheme ...

I'll prepare a patch and submit

Sylvain