I've run this service again for our euRobotics 'simulation' deployment (see
- Maybe instead of the connection name, we could indicate the connection
type instead. With the words 'buffer[size]' or 'data' for example. The long
names impair readability and don't give any extra information.
- Readability might improve if the arrows leaving an output port or entering
an input port would originate from the same point. I have no idea to do
this.. drawing another 'icon' which represents a port would not guarantee
that the port icon stays close to the component in the drawing.
- We might need another service to display peer connections. I don't think
its readable to show both.
- Ports of services are not done yet..? We could show services which have
ports as ovals as well, but again, these could be relocated far away by the
Anyway, very usable as it is... and independent of ROS :-)