[Bug 476] New: replace/add funcInternal by funcHook

For more infomation about this bug, visit
Summary: replace/add funcInternal by funcHook
Product: BFL
Version: trunk
Platform: All
OS/Version: All
Status: NEW
Severity: enhancement
Priority: P2
Component: core
AssignedTo: bfl [..] ...
ReportedBy: klaas [dot] gadeyne [..] ...
CC: bfl [..] ...
Estimated Hours: 0.0

To lower the code-readability-threshold of orocos-subprojects it would be nice
if BFL would use the same conventions as the RTT in terms of function naming.
Hence I suggest to replace the funcInternal() functions by a funcHook()
equivalent and add some Hook() extensions to other non-public class methods to
stress the fact they are not part of the public API of BFL classes.

e.g.

- replace UpdateInternal with UpdateHook for most filter classes
- add Hook() extensions to the SysUpdate() and MeasUpdate() functions of
KalmanFilter classes