[Bug 515] New: Names of the KDL-types in a propertyfile

For more infomation about this bug, visit
Summary: Names of the KDL-types in a propertyfile
Product: KDL
Version: kdl-trunk
Platform: All
OS/Version: All
Status: NEW
Severity: normal
Priority: P2
Component: Plugin
AssignedTo: orocos-dev [..] ...
ReportedBy: ruben [dot] smits [..] ...
CC: orocos-dev [..] ...
Estimated Hours: 0.0

Now the names of kdl-types in a propertyfile should be:

MotCon::Type

i would like to change this in:

KDL::Type,

i know this means everyone using the KDLToolkit has to change their
propertyfiles so i would like to have some feedback before i commit this on
trunk:

Should the name in the propertyfile be the same as in the scripting? I.e.
KDL::Vector in a propertyfile is a vector in scripting, KDL::Frame becomes
frame.

If yes, should we omit the "KDL::" or add the KDL:: to the scriptingnames?

Ruben

[Bug 515] Names of the KDL-types in a propertyfile

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
CC| |peter [dot] soetens [..] ...

--- Comment #3 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-10 11:05:03 ---
I had a comment on this patch. For backwards compatibility, you could have
done:

if ( bag.getType() == "MotCon::Rotation" || bag.getType() == "KDL::Rotation"
) {
bag.setType( "KDL::Rotation" );
....
}

etc. This would allow you to read all kinds of cpf files, but during write, use
the new type.

For the rest, I'm in favor of this patch.

Ruben Smits's picture

[Bug 515] Names of the KDL-types in a propertyfile

For more infomation about this bug, visit

Ruben Smits <ruben [dot] smits [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Status|NEW |RESOLVED
Resolution| |FIXED

--- Comment #2 from Ruben Smits <ruben [dot] smits [..] ...> 2008-02-29 12:07:15 ---
Since nobody reacted i presume it's ok for everybody

svn ci src/bindings/rtt/motionproperties.cpp -m"Fixing bug #515: Names of the
KDL-types in a propertyfile by applying patch #238"
Sending src/bindings/rtt/motionproperties.cpp
Transmitting file data .
Committed revision 29005.

Ruben

Ruben Smits's picture

[Bug 515] Names of the KDL-types in a propertyfile

For more infomation about this bug, visit

--- Comment #1 from Ruben Smits <ruben [dot] smits [..] ...> 2008-02-15 17:41:11 ---
Created an attachment (id=238)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=238)
Patch to change the property names