[Bug 522] New: Not needed to use TAO_IDL_BE

For more infomation about this bug, visit
Summary: Not needed to use TAO_IDL_BE
Product: OCL
Version: trunk
Platform: All
OS/Version: All
Status: NEW
Severity: normal
Priority: P2
Component: Documentation / Web site
AssignedTo: orocos-dev [..] ...
ReportedBy: jwillemsen [..] ...
CC: orocos-dev [..] ...
Estimated Hours: 0.0

The installation instructions on
http://www.orocos.org/stable/documentation/rtt/v1.4.x/doc-xml/orocos-installation.html#install-config-corba
are invalid to my idea.

It mentions TAO_IDL_BE as library to link with, but this is the backend of the
TAO IDL compiler, I don't think your system should link with it. Also the TAO
version mentioned is ancient, the doc_group version of ACE/TAO is very stable
now, but you have to link with more libs

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Status|REOPENED |RESOLVED
Resolution| |FIXED

--- Comment #8 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-28 09:26:47 ---
$ svn ci xml/orocos-installation.xml -m"Fixes bug #522: Not needed to use
TAO_IDL_BE. Final 'neutral' documentation fix."
Sending xml/orocos-installation.xml
Transmitting file data .
Committed revision 29124.

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Attachment #256 is|0 |1
obsolete| |

--- Comment #7 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-27 13:14:31 ---
Created an attachment (id=257)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=257)
Same as fix-tao-refs-2, but also indicate that support is available for both
versions.

fix-tao-refs-2

Well, the problem is that it does not work with both versions and this is a problem for the users that do not have the working version.
===============================
Tiberiu - [Drug Rehab Program|http://lupusurvivor.com/?p=557]
===============================

fix-tao-refs-2

On Wednesday 28 January 2009 11:43:09 ceocoiu [dot] cristian [..] ... wrote:
> Well, the problem is that it does not work with both versions and this is a
> problem for the users that do not have the working version.

(this refers to <https://www.fmtc.be/bugzilla/orocos/show_bug.cgi?id=522>,
please use 'quote' when replying on the forum)

Do you have evidence that this change broke backwards compatibility and with
which version ?

Peter

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

--- Comment #6 from Johnny Willemsen <jwillemsen [..] ...> 2008-03-27 12:13:18 ---
(In reply to comment #4)
> (In reply to comment #2)
> > (In reply to comment #1)
> I could not find a patched TAO release on the Remedy
> site for example. In the past, we really had broken DOC versions and rock solid
> OCI versions. If this happens again, I want our users to know they have a
> choice. The OCI version is equally free available as the DOC version.

We as Remedy don't have a patched release, we support any TAO version (doc
group and OCI) and only deliver small patches to solve one problem. In the past
the doc version was broken frequently, but that doesn't happen anymore

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

--- Comment #5 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-27 12:09:40 ---
Created an attachment (id=256)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=256)
Even more neutal, but still distinguish OCI vs DOC.

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Status|RESOLVED |REOPENED
Resolution|FIXED |

--- Comment #4 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-27 11:44:37 ---
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=255)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=255) [details] [details]
> > Updates TAO section for neutrality and link flags
>
> Riverace doesn't support TAO, only ACE. PrismTech has also their own
> distribution. If you want to be real neutral refer to this link for commercial
> support: http://www.cs.wustl.edu/~schmidt/commercial-support.html, we as Remedy
> IT support ACE/TAO and are listed there

Ouch ! What a typo. I wanted to attribute the Remedy support and along the way,
it changed into Riverace. I had skimmed the Changelog file for references.

I still want to distinct between the OCI version and the DOC versions as both
are separate releases. I could not find a patched TAO release on the Remedy
site for example. In the past, we really had broken DOC versions and rock solid
OCI versions. If this happens again, I want our users to know they have a
choice. The OCI version is equally free available as the DOC version.

So I'll mention the two versions and the general commercial support link.

>
> You lack a few libs when using doc_group TAO 1.5 or newer, libs like TAO_PI,
> TAO_PI_Server and more
>

I've just skimmed the release notes, and porting will be required to use TAO
1.5 (or 1.6), so I'll drop that 'later versions' statement again. We'll move to
these version when Debian/Ubuntu moves.

Peter

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Status|ASSIGNED |RESOLVED
Resolution| |FIXED
Target Milestone|--- |1.4.2

--- Comment #3 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-27 10:17:16 ---
$ svn ci -m "Fix bug #522: Not needed to use TAO_IDL_BE. Applied patch #255."
Sending xml/orocos-installation.xml
Transmitting file data .
Committed revision 29123.

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

--- Comment #2 from Johnny Willemsen <jwillemsen [..] ...> 2008-03-27 10:16:04 ---
(In reply to comment #1)
> Created an attachment (id=255)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=255) [details]
> Updates TAO section for neutrality and link flags

Riverace doesn't support TAO, only ACE. PrismTech has also their own
distribution. If you want to be real neutral refer to this link for commercial
support: http://www.cs.wustl.edu/~schmidt/commercial-support.html, we as Remedy
IT support ACE/TAO and are listed there

> To be fair, it has been a few years since I've used the OCI version and
> most users are using the DOC group version, packaged for Debian.
>
> So I made the statements neutral and added a reference to other support
> companies as well.
>
> The wrong link flag has been removed as well.

You lack a few libs when using doc_group TAO 1.5 or newer, libs like TAO_PI,
TAO_PI_Server and more

[Bug 522] Not needed to use TAO_IDL_BE

For more infomation about this bug, visit

Peter Soetens

<peter [dot] soetens [..] ...> changed:

What |Removed |Added
--------------------------------------------------------------------------
Status|NEW |ASSIGNED
AssignedTo|orocos- |peter [dot] soetens [..] ...
|dev [..] ... |

--- Comment #1 from Peter Soetens

<peter [dot] soetens [..] ...> 2008-03-27 10:12:18 ---
Created an attachment (id=255)
--> (https://www.fmtc.be/bugzilla/orocos/attachment.cgi?id=255)
Updates TAO section for neutrality and link flags

To be fair, it has been a few years since I've used the OCI version and
most users are using the DOC group version, packaged for Debian.

So I made the statements neutral and added a reference to other support
companies as well.

The wrong link flag has been removed as well.